HandheldCare: Support

 

Support

Please contact support@handheldcare.com

For questions about HandheldCare products:

You will need an iPhone 3G, or an original iPhone or iPod Touch that has been upgraded with Firmware 2.0. You will also need a Mac or PC computer installed with iTunes. The firmware update is available through iTunes.

What do I need to get these applications?

The iPhone 3G and iPod Touch offer a new dimension in clinical handheld computing. The improved graphics, interface, memory, and software installation process will bring many more healthcare providers to see the benefits of a handheld computer in clinical practice.

Why would I want these applications?

iPod, iPod Touch, iPhone, and iTunes are Registered Trademarks of Apple, Inc.